安装NLTK

NLTK需要Python版本3.5、3.6、3.7或3.8

对于Windows用户,强烈建议您通过本指南成功安装python 3 https://docs.python guide.org/starting/install3/win/install3 windows

设置python环境(mac/unix/windows)

请阅读本指南,了解如何在安装NLTK之前管理虚拟环境管理器,https://docs.python-guide.org/dev/virtualenvs/

或者,您可以使用包含“电池”的Anaconda Distribution安装程序https://www.anaconda.com/distribution/

MAC/UNIX

  1. 安装NLTK:运行 pip install --user -U nltk

  2. 安装numpy(可选):运行 pip install --user -U numpy

  3. 测试安装:运行 python 然后类型 import nltk

对于旧版本的python,可能需要安装setuptools(请参见http://pypi.python.org/pypi/setuptools)并安装pip (sudo easy_install pip

Windows

这些说明假定您的计算机上尚未安装python。

32位二进制安装

  1. 安装Python 3.8:http://www.python.org/downloads/(避免使用64位版本)

  2. 安装numpy(可选):https://www.scipy.org/scipylib/download.html

  3. 安装nltk:http://pypi.python.org/pypi/nltk

  4. 测试安装: Start>Python38 然后类型 import nltk

安装NLTK数据

安装完NLTK包后,请安装必要的数据集/模型,以使特定功能正常工作。

如果您不确定需要哪些数据集/模型,可以在命令行类型上安装NLTK数据的“热门”子集。 python -m nltk.downloader popular 或者在python解释器中 import nltk; nltk.download('popular')

有关详细信息,请参阅http://www.nltk.org/data.html