安装(1.x)

注解

安装Fabric 2.0或更高版本?查找非pypi下载或源代码签出说明?见 安装 .

本文档包含有关安装Fabric 1.x的旧说明。强烈建议用户尽可能升级到2.x。

基本安装

最好通过以下方式安装 Fabric pip ::

$ pip install fabric

所有先进 pip 用例也可以工作,例如:

$ pip install -e git+https://github.com/fabric/fabric

或者克隆Git存储库并运行:

$ pip install -e .

在它里面。

您的操作系统也可能有一个结构包可用(尽管这些包通常较旧,而且难以支持),通常称为 fabricpython-fabric . 例如。::

$ sudo apt-get install fabric

依赖关系

为了使Fabric的安装成功,您需要四个主要的软件:

  • python编程语言;

  • 这个 setuptools 包装/安装库;

  • Python Paramiko SSH文库;

  • 以及帕拉米科的依赖, Cryptography .

如果使用并行执行模式,

请继续阅读,了解每个依赖关系的重要细节——有几个问题。

Python

Fabric 要求 Python 版本2.5 +。

设置工具

Setuptools 默认情况下,大多数的python安装都会提供;如果没有,则需要获取它。在这种情况下,它通常被包装成 python-setuptoolspy26-setuptools 或者类似的。

multiprocessing

一个可选的依赖项, multiprocessing 在2.6及更高版本中,库包含在Python的标准库中。如果您使用的是python 2.5,并且想要利用fabric的并行执行功能,那么您需要手动安装它;通常推荐的路由是通过 pip . 请看 multiprocessing PyPI page 有关详细信息。

警告

早期版本的python 2.6(在我们的测试中,2.6.0到2.6.2)附带了一辆小车 multiprocessing 在涉及大量并发主机的会话结束时似乎导致结构挂起的模块。如果遇到此问题,请使用 env.pool_size / -z 限制并发量,或者升级到python>=2.6.3。

python 2.5不受影响,因为它需要pypi版本的 multiprocessing ,比python<2.6.3提供的更新。

ActivePython和Pypm

已具有ActiveState的Windows用户 ActivePython 安装的分发可能会发现最好使用 its package manager, PyPM . 下面是通过 pypm ::

C:\> pypm install fabric
The following packages will be installed into "%APPDATA%\Python" (2.7):
 paramiko-1.7.8 pycrypto-2.4 fabric-1.3.0
Get: [pypm-free.activestate.com] fabric 1.3.0
Get: [pypm-free.activestate.com] paramiko 1.7.8
Get: [pypm-free.activestate.com] pycrypto 2.4
Installing paramiko-1.7.8
Installing pycrypto-2.4
Installing fabric-1.3.0
Fixing script %APPDATA%\Python\Scripts\fab-script.py
C:\>